Jul 21, 2024  
2010-2011 Denver Campus Catalog 
    
2010-2011 Denver Campus Catalog [ARCHIVED CATALOG]

Computer Requirements


In order to make the most of your online learning experience, there are  several technical requirements you will need to fulfill. Refer to the guidelines below.
   

eCollege System Requirements

Blackboard System Requirements

   
Microsoft Windows Microsoft Windows
* Windows 2000 or XP * Windows 2000 XP, or Vista (Vista users, please see below.)
* 64 MB RAM * 2 Gigabytes of RAM and 20 Gigabytes of free disk space on your primary hard drive (usually labeled the “C” drive)
* 28.8 kbps modem (56K Recommended) * 28.8 kbps modem (56K recommended)
* SoundCard & Speakers * SoundCard & Speakers
   
   

At least one of the recommended PC browsers with Java needs
to be enabled, although we recommend having two browsers:

At least one of the recommended PC browsers with Java needs to be enabled,
although we recommend having two browsers:
* Internet Explorer 7.0 (recommended) * Internet Explorer 7.0 (supported)
* Internet Explorer 6.0 (supported) * Internet Explorer 6.0 (supported)
  * Internet Explorer 5.5 (supported)
* Netscape Communicator 7.1 (supported) * Netscape Communicator 7.1 (supported)
  * Firefox 3 (recommended)
* Firefox 3 (recommended) * Firefox 2.0 (supported)
* Firefox 2.0 (supported) * Firefox 1.x (supported)
   
 Macintosh OS
* MacOS 9.1 and OS X
* 32 MB RAM (64 Recommended)
Vista users: Blackboard has tested Release 7 of the Blackboard Academic Suite with Microsoft Windows Vista using both the Microsoft Internet Explorer 7.0 Web browser and the Firefox 2.0 Web browser. The results of the testing show that Microsoft Windows Vista is compatible.
* 28.8 kbps modem (56K Recommended)
* Sound Card & Speakers


At least one of the recommended MAC browsers with Java needs 
to be enabled, although we recommend having two browsers:
Compatible configurations are partially tested by Blackboard and should function as expected. In this instance, Blackboard has conducted several weeks of testing to determine compatibility. Users that have upgraded to Microsoft Windows Vista should feel comfortable using it with Microsoft Internet Explorer 7 or Firefox 2.0 to access the Blackboard Academic Suite, Release 7. 
* Netscape Communicator 7.1 (supported) However, please be aware of the following issues uncovered during testing:

* Safari 3.0 (recommended for OS X)
* Safari 2.0 (supported for OS X)
AS-102054: The Visual Text Box Editor controls do not function correctly in Internet Explorer 7 because they require a component not available in Windows Vista. Users using Internet Explorer 7 when interacting with UC Denver’s Blackboard, should turn off the Visual Text Box Editor in their personal preferences or use Firefox version 2.0, or higher.
* Firefox 3 (recommended)  
* Firefox 2.0 (supported) Macintosh OS
  * MacOS 9.1 and OS X
  * 2 Gigabytes of RAM and 20 Gigabytes of free disk space on your primary hard drive (usually labeled the “C” drive)
  * 28.8 kbps modem (56K Recommended)
  * Sound Card & Speakers
  * Recommended Software
   
  At least one of the recommended MAC browsers with Java needs to be enabled, although we recommend having two browsers:
  * Netscape Communicator 7.1 (supported)
  * Netscape Communicator 6.2 (supported)
  * Safari 3.0 (supported for OS X)
  * Safari 2.0 (recommended for OS X)
  * Safari 1.2 (supported for OS X)
  * Firefox 3 (supported)
  * Firefox 2.0 (supported)
  * Firefox 1.x (supported)
   
 
 
   

Internet Service Provider (ISP)

An ISP is a company that provides you with the software and access necessary for getting onto the Internet. You will need Internet access to take your courses.
 

E-mail Account

Your e-mail address is established when you sign up with an ISP. Check with your ISP if you do not know what your e-mail address is. Special characters can
cause problems with some systems that make it difficult to reach the intended mailbox. We suggest that you do not use special characters, for example +, &, $,
etc., in your e-mail address.
 

Java Capable Browser

We support Microsoft Internet Explorer 5.5 and 6.0 for Windows and Internet Explorer 5.1 through 5.2 for Macintosh. Netscape Communicator 6.2 and 7.1 for
Windows and Netscape Communicator 7.1 and Safari 1.x for Macintosh, are also supported.
 
For additional information, go to www.cuonline.edu.